Jump to content

Welcome to NulledBlog
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

bot mysql error


  • Please log in to reply
3 replies to this topic

#1
ReqqEST

  • Offline
  • Advanced Member

  • Posts:
    108
    Reputation:
    0
    Joined:
    28 Sep, 2015
Hey guys so I've been having problems with my bot. I will put the bot up and It will work for a few minutes. But then the bot crashes and I get this error. If anyone knows how to fix it pls tell me. I've ran the bot on a local machine and vps. 
 
C:\Users\qw\Desktop\freshaf\sitek\bot>node bot.js
[SERVER] The Bot has logged in!
events.js:141
      throw er; // Unhandled 'error' event
      ^
 
Error: Connection lost: The server closed the connection.
    at Protocol.end (C:\Users\qw\Desktop\freshaf\sitek\bot\
node_modules\mysql\lib\protocol\Protocol.js:103:13)
    at Socket.<anonymous> (C:\Users\qw\Desktop\freshaf\site
k\bot\node_modules\mysql\lib\Connection.js:102:28)
    at emitNone (events.js:72:20)
    at Socket.emit (events.js:166:7)
    at endReadableNT (_stream_readable.js:905:12)
    at nextTickCallbackWith2Args (node.js:474:9)
    at process._tickCallback (node.js:388:17)
 
C:\Users\qw\Desktop\freshaf\sitek\bot>pause
Press any key to continue . . .
 
 

  • 0

#2
AndreasGoette

  • Offline
  • Member

  • Posts:
    37
    Reputation:
    2
    Joined:
    29 Feb, 2016

do you have the required ports open ? (portforwarding in your router)


  • 0

#3
ReqqEST

  • Offline
  • Advanced Member

  • Posts:
    108
    Reputation:
    0
    Joined:
    28 Sep, 2015

do you have the required ports open ? (portforwarding in your router)

I'm running it on a VPS


  • 0

#4
AndreasGoette

  • Offline
  • Member

  • Posts:
    37
    Reputation:
    2
    Joined:
    29 Feb, 2016

ok, for VPS: here you got a video tutorial how to portforward a VPS ... if the ports are blocked the bot need, it wouldnt work ...

 

https://www.youtube....h?v=FTs5eMJDdjs

 

after that check your VPS Firewall, if the ports are open there too, with using SSH to connect to it - if you need help there too, write to me ;-)


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users